
 

Page 1 of 11 

 

 

 

 

Leica iCON office V2024.1.3  

Release Notes 

 

Date:  30th January 2024 

From:  Torgny Israelsson 

 

 

iCON office release of version 2024.1.3 – Release notes 

We are pleased to announce a new release of iCON office, version 2024.1.3. This release includes 

improvements regarding merging and extending of TIN models. A model of for example a house slab, 

can be extended with a horizontal or a slope offset, or a combination of both. 

 

 
 

The workflow for stockpiles is improved, so it’s both easier and faster to report volumes of stockpiles 

direct from point cloud or multiple TIN models. 

 

A selection of other new features: 

▪ Improved visualization difference models, so the user easily can identify areas with positive or 

negative height differences. 

▪ PDF viewer and import of vectorized data to DWG. 

▪ The used folder structure on Leica ConX is listed in the import/export dialog in iCON office and 

files can be uploaded or downloaded to/from any specific folder. 

 

And as always, we are continuously improving the import/export options in iCON office. Please, read the 

release notes for more detailed information. 

 

All users with a valid maintenance will be able to install and run this new version and migrate to Leica 

EID licensing.  
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 New Functions and Improvements

1.1 Stockpiles 

1.1.1 From Terrain Models 

A new dedicated menu option to calculate volumes of stockpiles, go to Functions > Volume Calculation, 
Stockpiles. 
 

▪ Opened stockpile models are pre-selected in the workflow view. 
▪ Possible to add description and material codes. 
▪ Create volume report of one or multiple stockpiles. 

o Options to save all volumes to the same or separate reports. 
o If saved to the same report, the volumes can be summarized: 

▪ By stockpiles - All volumes are summarized. 
▪ By code - Only volumes with same material code are summarized. 

 

 
 

1.1.2 From Point Cloud 

New tool, Calculate Stockpile from Point Cloud, to extract and calculate volumes of stockpiles direct from 
point cloud. The manual first step to created TIN surfaces, is not required. Select the tool and draw a 
polygon around the stockpile. 
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▪ Preview of generated stockpile surfaces. 
▪ Volumes are listed in the workflow view to the right. 
▪ Possible to add description and material codes. 
▪ Create volume reports of one or multiple stockpiles. 

o Options to save all volumes to the same or separate reports. 
o If saved to the same report, volumes can be summarized: 

▪ By stockpiles - All volumes are summarized. 
▪ By code - Only volumes with same material code are summarized. 

▪ If required, the used stockpile surfaces can be saved as TIN models. 
 

1.2 Terrain Model Improvements

The Data menu, with all available options for the 
active terrain model, is updated and the options 
are grouped in a more logical way. The option, 
merge models, can now be found here. 
 
In addition, we have developed new 
functionality, and the two new options are 
called: 
 

▪ Extend Model 
▪ Stitch model 

 
As new default, terrain models are opened in 3D 
graphics. If you right click on a terrain model in 
the project tree, it’s still possible to select the 
option to open them in 2D. 
 
 

 
 

1.2.1 Extend Model 

New function to extend TIN models, e.g. design models of house pads with user defined parameters. 

▪ A horizontal offset and/or a slope offset to a defined height level can be added. 
▪ A preview of the extended surface with current parameters is visualized in 3D window. 
▪ If required, the source model can be extended in multiple steps and finally saved as a new model 

(*.trm). 
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1.2.2 Stitch Models 

If you have two models, that are not overlapping, but they should be connected, iCON office has a new 
function to stitch two models, based on a horizontal distance. 
 

▪ A user defined maximum horizontal distance must be added in the workflow view. 
▪ A preview of the result is visualized in 3D window. 
▪ The stitched model can be saved as a new model.  

 

 

1.2.3 Merge Model with Prioritization  

The option called Prioritized model is improved and no user defined slope values must be used at the 
intersections between the two models. The prioritized surface is just merged into the source model in 
overlapping areas. If required, it’s still possible to define cut and fill slopes for the intersection areas.  
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1.3 Difference Models 

▪ The visualization of difference model (dfm) is improved and as default, the areas with negative or 
positive height are colored blue and red, but colors can be modified in the property dialog.  

▪ The property dialog is updated. 
▪ Possible to export difference models to DWG, select View > Save View As > AutoCAD file. 
▪ A difference model node is added to the project tree to improve the overview of files within a 

project. Before dfm was listed among terrain models. 
 

 

1.4 Point Cloud 

▪ A new tool to calculate volumes of stockpiles direct from stockpiles. 
▪ Dynamic selection – The selected area for processing, when using any of the point cloud tools, is 

visualized dynamically to make it easier to select correct areas. 
▪ Measure tool – Improved visualization of the measure tool, when it’s used in combination with 

point cloud. 
▪ Point clouds imported from LAS/LAZ – User defined classes are listed in the classification filter. 

o The classification dialog is updated with more options e.g., point count for each class. 
o Possible to turn on classification colors for certain classes. 
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1.5 Leica ConX 

▪ The folder structure used in ConX projects is now listed in the import/export dialog of iCON 
office. 

o Files can be uploaded to or downloaded from any folder in ConX. 
o Possible to create new and delete folders in ConX from iCON office. 

 

 
 

▪ New option to select the correct data type when uploading files, for example reference model or 
avoidance zones etc. 
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1.6 PDF Import 

▪ PDF Viewer – Raster and vector PDF files can be opened and visualized. 
▪ Two import options in the workflow view: 

o Vectorized data as AutoCAD DWG 
o Raster data as image, which can be used as background image, if an image 

transformation, georeferencing, is done. 
 

 
 

▪ Two new options when a DWG file is exported as PDF (Data > Create PDF > 2D PDF/3D PDF 
o Orientation - Portrait, or landscape can be set. 
o Paper size - A4, A3, A2 or A1 can be selected. 
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1.7 AutoCAD 

The option to export your iCON office view to AutoCAD format is moved and is now found at the top of 
the menu, View (View > Save View As > AutoCAD File). The data that you see in your graphic 2D 
window will be exported to an AutoCAD file. This option to export to AutoCAD format has more features 
compare to the simplified export available in the import/export dialog. 
 

 
 

▪ Delete Layout – In the dialog, Set Active Layout, an option to delete layouts is added. 
▪ Updated ODA library. 

1.8 IREDES Import 

▪ Import of drill/piling holes to a coordinate file, no export. 
 

1.9 Tunnel 

▪ Export of tunnel section files (tun) to DXF. 
▪ The method to interpolate tunnel sections is updated. Start/mid/end of the arcs are interpolated 

and then the radius of the interpolated element from three points are calculated.

  

1.10 Bug Fixes and Maintenance 

In addition, a lot of annoying bugs have been solved and maintenance improvements done.  

▪ Updated IFC library 
▪ LandXML import - Improved import of alignments when the file has redundant information 

regarding start stationing (conflict between staStart vs individual elements).is 
▪ LandXML import - The numerical part of line codes is not truncated anymore, so the codes will 

be unique (LandXML from Gemini). 
▪ Text file import - When using a text import filter, it can be selected by double clicking the filter. 
▪ Text file export - The last used export settings are saved. 
▪ The cross-section generation method for terrain models (*.trm) is improved and is now the same 

as is if the surface is a DWG. The change will solve some issues in trench model and MBS. 
▪ Parallel line tool didn't work as expected. Fixed. 
▪ Create cross section and profile did not work from UIM 3D-view. Fixed. 
▪ Snap to perpendicular was broken when drawing polyline and using undo. Fixed. 
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 iCON office Licensing 

 

2.1 Articles 

iCON office starts with Core, which enables import/export of data, 3D visualization, COGO calculations, 

coordinate system handling, visualization in Google Earth and generating of drawings etc. 

Base Software 

971847 iCON office Core It features import/export and COGO functionality and can be upgraded 

with various options. 

Options 

971848 iCON office Road iCON office Core is required for upgrading. 

971849 iCON office Terrain iCON office Core is required for upgrading. 

971854 iCON office Trench iCON office Core and Terrain are required for upgrading. 

971853 iCON office Point Cloud iCON office Core and Terrain are required for upgrading. 

971850 iCON office Volume iCON office Core, Road and Terrain are required for upgrading. 

971851 iCON office Tunnel iCON office Core, Road and Terrain are required for upgrading. 

971852 iCON office Net Adjustment iCON office Core is required for upgrading. 

CCP 

6017858 1yr iCON office CCP iCON office CCP extended one year 

6017859 2yr iCON office CCP iCON office CCP extended two years 

6017860 3yr iCON office CCP iCON office CCP extended three years 

Migration 

971913 iCON office Migration Migration from dongle to EIDs. Valid CCP is required. 

Re-activation  

5311599 Re-activation Fee iCON office 

(>1yr) 

Re-activation Fee iCON office (>1yr) applied if maintenance expired for 

+365days 

 

2.2 Important Changes - New License Model 

Since the release of iCON office 2023, iCON office is delivered using the EID license model and no 
physical delivery of USB dongles is required. The licensing is aligned and work in a similar way as for 
other software products from Leica Geosystems. 
 

▪ iCON office is delivered as EID license. 

o Licensing of EIDs is managed through CLM. 

o Floating license – All iCON office licenses are floating licenses. 

o Physical delivery of USB dongles is no longer supported. 

▪ iCON office version 2023 can also start with a USB dongle with a valid maintenance.  

o But it will not be possible to update or add new license options to a dongle-based license without 

first migrate to EID license. 

o It’s recommended to migrate to EID license. 

 

 

 

 

 

 



 

Page 11 of 11 

 

2.3 Migration

2.3.1 Migration with active Maintenance 

▪ All customers with active maintenance can migrate with article 971913 and will be issued a new EID to 

replace the dongle. This EID will honor the product(s) and maintenance date of their existing dongles. 

o Provide serial number (4- or 5-digit number) or dongle ID, available on the plastic tag, when 

ordering migration. 

▪ Customers are responsible for running Dongle Tool and check in the license to the license server, after 

delivery of their new EID. 

o The dongle must not be returned to Leica Geosystems  

▪ If a customer wants to upgrade with more license options, this must be done in a second step. 

2.3.2 Migration without active Maintenance 

▪ All customers without active maintenance must purchase a new maintenance (CCP) contract at the time of 

migration (1yr, 2yr or 3yr iCON office CCP) 

o Provide serial number or dongle ID when ordering CCP and migration. 

▪ Customers are responsible for running Dongle Tool and check in the license to the license server, after 

delivery of their new EID. 

o The dongle must not be returned to Leica Geosystems. 

▪ If a customer wants to upgrade with more license options, this must be done in a second step.  

 

 Leica myWorld 

Please use Leica myWorld to find the latest version of iCON office. Access Leica myWorld by using the 

following link:  

https://myworld.leica-geosystems.com/

 

https://myworld.leica-geosystems.com/

