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Release of iCON office version 2024.2.1 

We are pleased to announce the release of iCON office, version 2024.2.1. The workflow when working 

with underground facilities is improved, both in the data preparation phase and when creating output like 

excavation models, cross sections, or volume reports. The new graphic tools for data preparation can of 

course be used in many different workflows. Please read the release notes for details. 

 

 
 

3D visualization of TIN models is further improved with support for both solid color and wireframe at the 

same time, to get a better 3D experience. The document property dialog for terrain models is updated 

and 2D and 3D are using the same dialog. New option to save defined colors for TIN models to file. 

 

All users with a valid maintenance will be able to install and run this new version and migrate to Leica 

EID licensing.  
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 New Functions and Improvements

1.1 Trench (UIM) 

1.1.1 Service Trenches 

Improved workflow when there is a main trench with underground utilities and multiple service trenches 
connecting to different properties. 
 

▪ Add Service Pipes – A new option in the Data menu for trench models (UIM). 
o Imported service pipes are listed at the new tree node called Service Pipelines. 

▪ Earthwork-Services – A new node where the settings for service trenches can be found and 
added. 

 
Input data for service pipes is a coordinate file with 3D lines for the different pipe profiles. It’s worth doing 
some data preparation using attributes to save time when importing all service pipes to the trench model. 
 

 
Pipe profiles. 

 
▪ Output from a trench model with service trenches: 

o Excavation model – Merged model with all service trenches and the main trench. 
o Separate volume reports for all service trenches. 
o Separate cross section files for all service trenches. 

 

 
Merged excavation model – main and service trenches. 
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1.1.2 Improved Traceability 

Improved traceability - Information about used source files for the pipes imported to the trench model is 
available in File > View/Edit File Info. 
 

 
 

1.1.3 Improved Excavation Model 

Data > Create Excavation Model - In the workflow pane for excavation models there is a new option 
called, Include Models. 
 

▪ If the option is selected the active models e.g., top surface and rock, and the defined calculation 
intervals, in the trench model, are used when the excavation model is created. A more detailed 
but heavier TIN model is created. 

▪ If not selected, the active models are not used, instead the user defined trench depth values are 
defining at which level the trench walls should stop. A very light weight theoretic TIN model is 
created. 

 

1.1.4 Flexible Rock Shelf 

Settings for rock shelf, when the trench is cutting through a rock layer, used to be global for the whole 
trench model but now the user can define the shelf different at different stations along the trench. 
 

▪ It possible to specify the stations where rock shelf should be used. 
▪ Difference widths can be defined. 

 

1.2 Data Preparation 

To speed up the process to add height and attributes to point and lines, there are two new tools and one 

improved graphic tool to make use of. 

 

▪    Add Height in Sequence  

o A new graphic tool to add height to points and lines by selecting one of the two options, Height or 

Slope %, in the drop-down list. 

▪   Pick Height from Text 

o Like a snap tool, it can grab a text height value from a DWG and add the height a coordinate file. 

▪    Set Point/Line Information 

o Two attributes selected from the active attribute list can be set to points and lines. 
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1.2.1 Add Height in Sequence      

Use this tool to add height to multiple points in a coordinate file. If the height should be fetched from Text 
or MText in a DWG, the tool could be used in combination with the snap tool, Pick Height from Text. 
 

1. Select the tool and information in the Input/output window says what to do next. 
2. Select a point to assign height to. 
3. Add height to the selected point by selecting one of the options Height, or Slope %, in the drop-

down list. 
a. Height - Type in a height value and confirm with [Enter]. 
b. Slope % - Add a percent value and confirm with [Enter], this option only works if the 

point before has a height value. The slope percent is used to calculate the height of the 
selected point. 

4. The next point in the line or next single point in the file, without height, is automatically selected 
and a height value can be added. 

 

 
 

 
 
 

1.2.2 Pick Height from Text 

This tool works similar as a snap tool, but it can pick a height value from Text or MText in a CAD file. It 
can be used in combination with Draw Point, Draw Line or Add Height in Sequence. 
 

1. Select, Pick Height from Text, and it make sense to activate multiple snap as well. 
2. Select a tool e.g. Add Height in Sequence 
3. Select a point. 
4. Pick/snap to a height from a Text or MText in a CAD file, confirm with a mouse click and the 

height is directly added to the point.  
5. The Add Height in Sequence tool automatically finds the next point in the line without height and 

another height can be picked from a Text/MText. 
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Pick Height from Text is fetching the height value 29.76 from the DWG and adding it to the selected point in the blue line. 

 

1.2.3 Set Point/Line Information 

Multiple points/lines can be edited in a 
sequence. If you have an active attribute list, it’s 
possible to select attributes to add to points or 
lines in a coordinate file by using this tool. 
 

1. Select the tool, Set Point/Line Info. 
2. Select a line representing a pipe. 
3. If an attribute file is defined (Edit> 

Preferences> Attributes) two attributes 
can be added to a line. 
 

a. "PipeServiceName" - Name of a 
service trench. If used, a 
service trench with this name is 
created during import and the 
service pipe is added to that 
trench. 

b. "PipeServiceFrom" - From 
which pipe in the main trench, 
the service pipe is connected 
to. If used, it’s possible to insert 
e.g. all water pipes to all service 
trenches with their specific 
settings at once. 

4. [OK] and click on the lines that should 
be updated with the new information. 

 
Select the tool again or use Alt+C to open the 
dialog again and change input. 
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1.3 Terrain Models 

1.3.1 Improved 3D Visualization and Updated Property Dialog 

The 3D visualization of terrain models is improved. 
 

▪ Support for both solid color and wireframe at the same time, which will improve the 3D 
experience. 

▪ Contour lines can now be visualized in 3D window. 
▪ Support for point visualization in 3D window. 

 

 
 

▪ Updated property dialog – 2D and 3D settings are merged to the same dialog. 
 
 

1.3.2 Save Colors to File  

Color support for terrain models - The selected colors can be saved to file, so the same set of colors are 
used next time the model opens in graphics. 
 
 

1.3.3 Extend Model with a Slope and Height Difference 

A new alternative, Height difference, to extend a terrain model is added to Data > Extend Model. 
 

▪ Required input is: 
o Height difference 
o Slope 

▪ The model is extended with the define slope until the height difference is achieved. 
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Preview of extended model with 1m horizontal offset, and a 1/1 slope until a height difference of 2m is reached. 

1.4 AutoCAD 

In addition to the new tool, Pick Height from Text, to fetch a height from Text or MText in a CAD file there 
is a new option to extract surfaces from solids. 
 

▪ In Data > Extract Surfaces from AutoCAD there is a new option to select if the highest or lowest 
level of a solid should be extracted as a surface, if a solid is a part of your selection.  

▪ A terrain model (TRM) is created. 
▪ The surface extraction from solids requires the terrain license. 

 

 
 
 
 
Tip!  
To make it easier to import the solid object you are interested in, use options the graphical right click 
menu for CAD files. 
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▪ Select the object of interest in the 
DWG/DXF. 

▪ Hover over the grip and right click, to list 
the options. 

▪ Use for example: 
 

o Hide Nonselected Layers, if 
the object is in a separate layer. 

o Hide Nonselected Objects, if 
there are many objects in the 
same layer and you only want 
to import e.g. a specific layer of 
road buildup solid. 
 

▪ Go to Data > Extract Surfaces from 
AutoCAD drawing use the option 
[Select Visible], to only extract the 
lowest or higest level of the visible 
object or obejcts. 

 

 
 

1.5 IFC  

▪ New option in the workflow view for IFC models, Extract solids as surfaces.  
o If selected, objects can be saved as a surface instead as points and lines.  

▪ The user defines if the highest or lowest level should be saved as a terrain model (TRM).  
▪ Requires the terrain license. 

 
 

 
Bridge foundations are selected for import and lowest level is defined in the settings. 
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The bridge foundation surfaces as TRM and extended with an offset, slope and height difference. 

 

1.6 Height from Cross Fall Model 

The function to update points with height values 
from a theoretic cross fall model (CFM) is 
updated with two options to limit points from 
being updated based on: 
 

▪ Start and end stations. 
▪ Side offset from center line (CL), left 

and right. 
o Negative values to the left of 

the CL. 
o Positive values to the right of 

the CL 
 

➔ Points outside the limits don’t get 
updated height values from the CFM. 
 

 
 

1.7 GeoCloud 

Support for a cloud storage, GeoCloud, 
featuring data transfer, creating folders etc.  
 

▪ The login can be found in the tab 
Services. 

▪ The Remote Service view is used for 
the upload/download of data. 
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1.8 LandXML 

 
▪ Support for LandXML surface with the color label, “M_Color”. The surface is visualized with color 

in the LandXML viewer and if imported, the terrain model will get the corresponding color. 
 

▪ Surfaces with breaklines in LandXML - The breaklines will be included in the created surface 
after import to TRM. 

 

 
LandXML viewer – Surface with breaklines and the imported TIN surface with breaklines. 

 
 

 Bug Fixes and Maintenance 

In addition, a lot of annoying bugs have been solved and maintenance improvements done.  

▪ Updated attribute files with attributes regarding trench model workflows. 
▪ PDF - In some cases when a PDF file was opened by drag and drop from project tree, the 

application could crash. Fixed 
▪ Point cloud imported from Leica *.xcf (MS60) lost intensity values. Fixed 
▪ Crash when selecting active file from the drop-down list of open files. Fixed 
▪ Trench - Selected calculation intervals in the workflow view was ignored when calculating pipe 

bedding. 
▪ Modify Selected Objects - Close button is renamed to Cancel and Modify is set as default. 
▪ Data>Modify Points - When creating filter, it didn’t work to use Enter to add a value to the filter. 

Fixed 
▪ In document properties for coordinate files there is a special setting for number of decimals for 

height values that overrides the project setting, that didn’t update properly when changes. Fixed
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 iCON office Licensing 

3.1 Articles 

iCON office starts with Core, which enables import/export of data, 3D visualization, COGO calculations, 

coordinate system handling, visualization in Google Earth and generating of drawings etc. 

Base Software 

971847 iCON office Core It features import/export and COGO functionality and can be upgraded 

with various options. 

Options 

971848 iCON office Road iCON office Core is required for upgrading. 

971849 iCON office Terrain iCON office Core is required for upgrading. 

971854 iCON office Trench iCON office Core and Terrain are required for upgrading. 

971853 iCON office Point Cloud iCON office Core and Terrain are required for upgrading. 

971850 iCON office Volume iCON office Core, Road and Terrain are required for upgrading. 

971851 iCON office Tunnel iCON office Core, Road and Terrain are required for upgrading. 

971852 iCON office Net Adjustment iCON office Core is required for upgrading. 

CCP 

6017858 1yr iCON office CCP iCON office CCP extended one year 

6017859 2yr iCON office CCP iCON office CCP extended two years 

6017860 3yr iCON office CCP iCON office CCP extended three years 

Migration 

971913 iCON office Migration Migration from dongle to EIDs. Valid CCP is required. 

Re-activation  

5311599 Re-activation Fee iCON office 

(>1yr) 

Re-activation Fee iCON office (>1yr) applied if maintenance expired for 

+365days 

 

3.2 New License Model since 2023 

Since the release of iCON office 2023, iCON office is delivered using the EID license model and no 
physical delivery of USB dongles is required. The licensing is aligned and work in a similar way as for 
other software products from Leica Geosystems. 
 

▪ iCON office is delivered as EID license. 

o Licensing of EIDs is managed through CLM. 

o Floating license – All iCON office licenses are floating licenses. 

o Physical delivery of USB dongles is no longer supported. 

▪ iCON office version 2023 can also start with a USB dongle with a valid maintenance.  

o But it will not be possible to update or add new license options to a dongle-based license 

without first migrate to EID license. 

o It’s recommended to migrate to EID license. 
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3.3 Migration with active Maintenance 

▪ All customers with active maintenance can migrate with article 971913 and will be issued a new 

EID to replace the dongle. This EID will honor the product(s) and maintenance date of their 

existing dongles. 

o Provide serial number (4- or 5-digit number) or dongle ID, available on the plastic tag, 

when ordering migration. 

▪ Customers are responsible for running Dongle Tool and check in the license to the license 

server, after delivery of their new EID. 

o The dongle must not be returned to Leica Geosystems  

▪ If a customer wants to upgrade with more license options, this must be done in a second step. 

3.4 Migration without active Maintenance 

▪ All customers without active maintenance must order 5311599, Re-activation Fee iCON office 

(>1yr), 

o Provide serial number or dongle ID when ordering re-activation and migration. 

▪ Customers are responsible for running Dongle Tool and check in the license to the license 

server, after delivery of their new EID. 

o The dongle must not be returned to Leica Geosystems. 

▪ If a customer wants to upgrade with more license options, this must be done in a second step.  

 

 Leica myWorld 

Please use Leica myWorld to find the latest version of iCON office.  

▪ myWorld >> my Downloads >> iCON >> iCON office) by using the following link:  

o https://myworld.leica-geosystems.com/

 

https://myworld.leica-geosystems.com/

