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Release of iCON office version 2025.2.2 
We are pleased to release Leica iCON office, version 2025.2.2.  
 
In this version, the focus has been on improving volume calculation and reporting.  
An example of features related to reporting is new options to add images or screenshots to reports. 
Workflow to calculate volumes from multiple surfaces and combinations of surfaces, and stockpiles from 
point clouds with surveyed boundaries, can now be done faster than before. A new function to calculate 
volumes directly from cross-section files is implemented. 
 
Other improvements relate to speeding up common tasks, such as file selection in some important 
workflow views and searching and opening files in a project. 
All users with valid maintenance will be able to install and run this new version.  
 
 
 

Please take your time to read these Release Notes! 
 
 

The release notes contain important information about the new version of the iCON office software and 
application features.  
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 Improvements

1.1 Volume Calculation 
Several improvements regarding volume calculations have been made. 
  

 A new function to calculate volumes directly from cross-section files with closed cross-section 
areas. 

 A smoother workflow if multiple model volumes should be reported. 
 In the tool, stockpile volumes from the point cloud, the surveyed perimeters of the stockpiles can 

be used to speed up the process. 
 

1.1.1 Volume Calculation from Cross Sections 

New option in the Data menu for cross-section files to calculate volumes directly from sec-files that 
contain cross-section areas. 
 

 
Cross-section with two closed areas. 
 

 Preview of calculated volumes in the workflow view. 
 It is possible to generate a volume report, including all available volumes in the cross-section file. 
 Requires the license option, Volume. 
 Volumes can be calculated between two layers with conditions e.g., between layer 1 and the 

highest of layer 2 and 3. 
 Flexible: 

o The user can cut cross sections from any available TIN models (Data > Create Terrain 
Sections). 

o The user can define their own cross-section areas in Data > Manage Areas 
o Tip 1! The function, Extend Model, can be used to extend one surface to make sure the 

two models intersect.  
o Tip 2! It’s possible to select a cross-section layer in the graphics and manually drag it, so 

two layers intersect. But it must be done at each section. 
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Dialogue to define or edit cross-section areas. 
 
 

1.1.2 Volume Calculation - Summarised 

New workflow to calculate multiple volumes between different combinations of surfaces. If used surfaces 
are open in graphics, the user has quick access to select input models for each calculation.  
 

 Two surfaces are selected, and the calculation can be given a name and added to the list of 
calculation results. 

o Preview of the results. 
o Material codes and descriptions can be added. 

 Another pair can be selected and added to the list, like in the first step. 
 When all combinations of volumes are calculated, the required report and other outputs can be 

created. 
 

 
The three volumes labelled as Total Cut, Base and Trench are calculated and added to the list. 
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Different report options: 
 

 One report, but each calculation is 
reported on an individual tab/page. 

 A compiled report, i.e. all calculated 
values are displayed on one tab/page. 

 A new report option that reports 
summed cut and fill volumes on the first 
tab/page. 

o All cut and fill volumes are 
summed up. 

o All cut and fill volumes are 
summed based on their 
material code. 

  
 

 

1.1.3 Stockpile Volumes from Point Cloud 

Improved workflow when calculating stockpile volumes from point cloud, and the perimeters of the piles 
have been surveyed in the field. 
 

 Surveyed files in the field can be used to define boundaries of stockpiles. 
 The line name is automatically used as the name of the stockpile, but it can be changed by the 

user. 
 Line code is used as material code, but it can be changed by the user. 

o If the line code is missing, the point code of the first point is used as material code. 
 AutoCAD export - In addition to a report, created stockpiles can be exported as surfaces to a 

DWG file, and each stockpile is added as an individual layer. If colours are used, the colour 
information is kept. 

 

 
Three stockpiles are created based on the surveyed polygons 
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1.2 Add Image to Reports  
There is support for adding images and screenshots to all reports. The images are added on a separate 
page, and a title and description can be added.  
 
An image can be added from: 
 

 Data > Add Image, and a dialogue to browse for the image is displayed. 
 View > Save View as > Image for Report, and the current graphical view is added as an image 

to the report. 
 

           
Dialogue to add a screenshot to a report  Report with image in print view 

  

Reports have an updated Data menu with useful functions: 
 

 Rename tab 
 Delete tab 
 Export to PDF or Excel 
 Toggle display views for report: 

o Data View - The current report 
view with tabs. 

o Print View - Print preview i.e., 
how the report is displayed if 
exported to PDF or printed. 

 To change the default display view for 
reports, go to:  

o Edit > Preferences > Printing 
and uncheck the option, Open 
reports in Print View. 

 

 

 
 
 
 
 
 
 
 



 

Page 8 of 13 
 

1.3 Improved File Selection in Workflow Views 
Several workflow views are updated with a new, 
faster option to select files for the different 
functions.  
 

 All open files of the right type are 
selectable in a drop-down list. 

 No need to manually browse and find 
the file in its subfolder  

 The old browse option is still available. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1.4 New Search Functions 

1.4.1 File Search 

Many customers work with large projects that contain many files saved in folders and subfolders. To 
make it easier to find specific files, a new search function for files in active projects has been developed. 
 

 Select Search > File Search to open the new search dialogue where you can search for files in 
the active project. 

 Found files can be opened and deleted from the dialogue. 
 It’s a non-modal dialogue, so the user can still interact with the application and graphics. 
 Setting to toggle between displaying the whole file path or just the file name. 

 

 
File search dialog 
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1.4.2 Command Search  

If you have problems finding a function, the new command search can be used to find the tool or menu 
option you are looking for and want to activate. 
 

 
Command search dialogue 
 
 

1.5 3D Graphics 
 The 3D graphics have been updated, which will improve the visualisation of heavy data sets and 

enable more graphical functions in the future.  
 

 If a computer has more than one graphics card installed, iCON office will automatically use the 
high-performance card.  

o If the integrated GPU is preferred, it can be changed in Edit > Preferences > General > 
GPU Preference 
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1.6 Bricsys 24/7 
Improved support for the cloud service, Bricsys 24/7: 
 

 In Bricsys 24/7 it’s possible to apply forms to certain folders on the server, which means that 
both required and non-required metadata can be added when files are uploaded. This workflow 
is now supported, and a dynamic dialogue is displayed during upload, so the user can add 
required information. 

 Naming of files on the server, based on added information, is supported for files uploaded from 
iCON office. 

 

1.7 Trench 
 The data menu for trench model (*.uim) is updated so that the different menu options, e.g. create 

excavation model or volume calculation, using workflow views, can be closed without having to 
close the trench model. 

 

1.8 Surveying – Traceability 
Traceability attributes on point level, earlier it was only on file level, are added when coordinates are 
calculated from surveyed data (*.plm): 
 

 Source file (sourceFile) 
 Source station (sourceStation) 
 Original point ID used in the plm-file (sourceRecord) 

 

 
 
 
 
 

1.9 Coordinate Files 
The new option, Convert radii to line segments, 
is available in the right-click menu for polylines. 
  
If the selected line has radii, the radius for each 
curve will be converted to short line segments 
based on a user-defined tolerance. 
 
 
 
 

 
 
 
 
 
 
 
 
 



 

Page 11 of 13 
 

1.10 LandXML Export Settings 
 
Settings are added to the LandXML export dialogue, so different XML extensions can be used when data 
is exported. If the HeXML extension is used when TIN surfaces are exported, many other Leica products 
can use the colour information.  
 
The different XML export options are: 
 

 No extension 
 HeXML 

o Can be used for additional 
information e.g., surface colours 
that is not supported in 
standard LandXML.  

o Default option 
 ISO 15143-4 

 
 

 
 

1.11 IFC 
IFC models contain a lot of different properties for objects to be displayed, and the user can decide which 
type of properties should be listed in the workflow view. 
 

 The last selected property type, to display in the workflow view for selected IFC objects, is now 
remembered during a file session. 

 Sync properties - If the option is ticked, multiple objects are selected, and the user would like to 
change the displayed property type for one object, the type is automatically changed for all 
selected objects. 
 

1.12 AutoCAD Export 
Support for utilising a dynamic scale-bar inside a DWG template paper layout. 
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 Bug Fixes and Maintenance 

 Some reports changed layout, and colour was added to alternate rows, after they were saved 
and reopened. Fixed  

 IFC - Deselection of objects was not reflected in the workflow view. Fixed 
 DWG Layout Workflow - When switching between layouts, the text labels in the workflow view 

were not updated. Fixed 
 DWG Export - The stored font selection was overwritten if a base drawing was used. Fixed 
 DWG Export - Using code list when exporting lines to DWG, the lines were only exported if the 

code had a block name defined. Fixed 
 Crop Model - Crash when a concave polygon was used for cutting a terrain model. Fixed. 
 Colour by elevation was not working correctly for certain models. Fixed with the new 3D graphic. 
 Excel Export - Allow both *.xlsx and the old *.xls, when exporting reports to Excel format. 
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 iCON office Licensing 

3.1 Articles 
iCON office starts with Core, which enables import/export of data, 3D visualisation, COGO calculations, 
coordinate system handling, visualisation in Google Earth and generating of drawings, etc. 

Base Software 
971847 iCON office Core It features import/export and COGO functionality and can 

be upgraded with various options. 
Options 
971848 iCON office Road iCON office Core is required for upgrading. 
971849 iCON office Terrain iCON office Core is required for upgrading. 
971854 iCON office Trench iCON office Core and Terrain are required for upgrading. 
971853 iCON office Point Cloud iCON office Core and Terrain are required for upgrading. 
971850 iCON office Volume iCON office Core, Road and Terrain are required for 

upgrading. 
971851 iCON office Tunnel iCON office Core, Road and Terrain are required for 

upgrading. 
971852 iCON office Net Adjustment iCON office Core is required for upgrading. 
CCP 
6017858 1yr iCON office CCP iCON office CCP extended one year 
6017859 2yr iCON office CCP iCON office CCP extended two years 
6017860 3yr iCON office CCP iCON office CCP extended three years 
Migration 
971913 iCON office Migration Migration from dongle to EIDs. Valid CCP is required. 
Re-activation  
5311599 Re-activation Fee iCON 

office (>1yr) 
Re-activation Fee iCON office (>1yr) applied if 
maintenance expired for +365days 

 

 Leica myWorld 
Please use Leica myWorld to find the latest version of iCON office.  

 myWorld >> my Downloads >> iCON >> iCON office) by using 
the following link: https://myworld.leica-geosystems.com/ 

https://myworld.leica-geosystems.com/
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